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2.0



Finder is the file manager for macOS 

When you look at the Desktop, you are using Finder, 
but so is using the Finder app directly



Components



Menu Bar



There’s only 1 menu bar, so if someone references a 
menu, that’s the one



 [App] File Edit View Window Help + others for each 
app



 shows you system-wide commands that are always 
available





Status menus (AKA menulets) are on the right of the 
menu bar



Holding down ⌥ on some status menus gives you 
additional info 







Holding down ⌘ allows you to move status menus 
around on the menu bar 



Tabs Tabs Tabs



Many apps already supported tabs, e.g., Chrome & 
Safari, or Finder 

Sierra enables (almost) every app to support tabs too, 
as long as the app supports multiple windows 

Holdouts? Microsoft Office



⌘T opens new tabs 

What if the app doesn’t support ⌘T (or it opens Show 
Fonts)?







😕



😕



Changing OmniOutliner with Keyboard Maestro



Changing Path Finder with Keyboard Maestro



Changing Transmit with Keyboard Maestro



Changing Safari with BetterTouchTool



Dialog Boxes



Always click on disclosure buttons







To open all disclosure boxes by default, open Terminal, 
enter the following on one line, & press ↩: 

defaults write -g 

NSNavPanelExpandedStateForSaveMode -bool true

Then do the same thing with this: 

defaults write NSGlobalDomain 

NSNavPanelExpandedStateForSaveMode2 -bool true



To check if all disclosure boxes open by default, open 
Terminal, enter the following on one line, & press ↩: 

defaults read NSGlobalDomain 

NSNavPanelExpandedStateForSaveMode

Then do the same thing with this: 

defaults read NSGlobalDomain 

NSNavPanelExpandedStateForSaveMode2

After each one, Terminal should return just this: 1



To close all disclosure boxes by default, open Terminal, 
enter the following on one line, & press ↩: 

defaults delete NSGlobalDomain 

NSNavPanelExpandedStateForSaveMode

Then do the same thing with this: 

defaults delete NSGlobalDomain 

NSNavPanelExpandedStateForSaveMode2



You can resize dialog boxes



⌘O to open a new document…



Grab & drag





Show the Finder location of a file from a dialog box



 Press ⌘R from within a dialog box… 



… & Finder opens showing the location of the file



Title Bar



Rename documents from the title bar









See all — & jump to any — of the folders that contain the 
current folder or file



⌘-click on the folder/window title





Original folder

Containing folder



⌘-click on the document title





Toolbars



Customize toolbars



View > Customize Toolbar… 

OR… 

Right-click on toolbar & select Customize Toolbar…



Finder





Safari



Path Finder



Keynote



DEVONthink



Sidebar





AirDrop



Add a link to AirDrop on your Dock 

In Finder, press ⌘⇧G

Enter: /System/Library/CoreServices/Finder.app/
Contents/Applications/ & press Enter 

Drag AirDrop to your Dock



Reorder



My order on the Finder 
Sidebar 

Based on order of use, with 
personal folders on the 
bottom



Finder 
Preferences



Click on the Finder icon on the Dock 

Finder > Preferences



I hide everything 
(I can see these in 
the sidebar under 
Devices & 
Shared)

I’d rather see my 
Home folder than 
All Files (which I 
find useless)



I check 
everything except 
for Movies & 
Music (I usually 
uncheck All My 
Files too) 

Note the Home 
folder is checked 
— it’s very useful



Make sure to 
show extensions 
(e.g., PDF, APP, & 
DOCX)

I don’t need 
warnings — I 
know what I did!

When I search, 
most of the time I 
want it to be in 
the current folder

For the former 
Windows users 
(not for me)



Views



Finder Views



4 Finder views

Icons ⌘1

Columns ⌘3

Cover Flow ⌘4

List ⌘2



Icons



List



Columns



Cover Flow



View Menu





View Options



Close any open Finder windows & click on your 
Desktop 

View > Show View Options





Open a Finder window that shows Downloads 

View > Show View Options







Arrange By 
organizes files 
into groups 

Sort By sorts 
files within 
groups



Quick Look

One of the best things about your Mac!



Introduced in 2007 with Mac OS X 10.5 Leopard 

Select a file & press ␣, & you see the contents of a file 
without actually opening it 

Press ␣ again to close it



Viewable by default 

» AAC 
» Adobe Photoshop 
» AVI 
» BMP 
» Excel 
» GIF 
» HTML 
» JPEG 
» MP3 

» MPEG4 
» PDF 
» PNG 
» PowerPoint 
» QuickTime movies 
» RTF 
» SVG 
» TEXT 
» TIFF 
» WAV 
» Word



Open in 
default 
app

Share 
sheet

Added in 
10.8 
Mountain 
Lion



Markup

Rotate

New in 10.14 
Mojave



Markup bar



Other Quick Look plugins enable viewing of other files 

Download the plugin & place the .qlgenerator file in 
~/Library/QuickLook (if the QuickLook folder doesn’t 
exist, create it) 

Either reboot or open Terminal & run qlmanage -r



BetterZipQL: contents of ZIP files



MultiMarkdown QuickLook: rendered Markdown files



MultiMarkdown QuickLook: rendered Markdown files



QuickLookJSON: JSON 
files with syntax 
highlighting



QuickLookCSV: CSV files as tables



QLStephen: shows plain text files, even those without 
an extension; e.g., README or LICENSE



InvisorQL: video & audio 
that macOS doesn’t 
support 

AVI: Audio Video 
Interleave



InvisorQL: video & audio 
that macOS doesn’t 
support 

FLAC: Free Lossless Audio 
Codec



InvisorQL: video & audio 
that macOS doesn’t 
support 

MKV: Matroska Video File



InvisorQL: video & audio 
that macOS doesn’t 
support 

WMV: Windows Media 
Video



Other ways to invoke Quick Look besides ␣ 

» ⌘Y 
» ⌥␣ to open in full screen 

Open an image with Quick Look & press ⌥ to zoom 
the image to actual size



Select 2 or more items 

Press ⌥⌘Y 

A slideshow opens with the selected items 

Close with ⎋



File 
Management



Select 2 or more files (or folders) 

Press ⌘⌃N & the selected files are gathered together in 
a new folder that you immediately rename 

You can also use File > New Folder with Selection 

(You can also do this with just 1 file if you want to 
quickly put it into a new folder)











Select files & folders in Finder & press ⌘C to copy them 

Press ⌘V to paste & therefore copy them to the new 
location, leaving the originals behind 

Press ⌥⌘V to move them to the new location, deleting 
the originals



File Info & 
Actions



Get Info, 
Get Summary Info, 
& Show Inspector



Get Info



Get Info shows the Info window, giving you 
information about the selected file, folder, or app 

To activate Get Info, make your selection & use… 

» File > Get Info 
» Right-click & click on Get Info 
» ⌘I



System 1.1 (1984)



System 1.1 (1984)



System 7.0.1 
(1991)



Tags for Finder 
& Spotlight

Comments for 
Spotlight

Don’t open as Retina

Allows changes to 
permissions

Permissions: Read & 
Write, Read only, No 
Access

Prevents any changes, 
including deletion,

Modified

Opened

General info



Share folder over 
a network

Number of items 
in folder



File-specific info

Change app that 
opens this file, or 
all files of this type 
(more coming up)

Change file into 
a template, & 
create a copy 
when opened 
(makes no sense 
with this PDF)



File-specific 
info

File-specific 
info,



File-specific 
info,

File-specific 
info



If you have 3 
files selected & 
press ⌘I, you get 
3 separate Get 
Info windows 

I’m going to add 
an image to 
Groucho and 
Me



Notice the Size 
changed (from 
217 KB to 475 
KB) & the 
Preview now 
shows the cover 
— without re-
opening the Get 
Info window



Get Summary Info



Get Summary Info shows the Multiple Item Info 
window, giving you information about the selected 
files, folders, or apps 

To activate Get Info, select two or more files & use… 

» Press ⌃ & File > Get Summary Info 
» Press ⌃ & right-click & click on Get Summary Info 
» ⌘⌃I



Gives me total 
size for the 
selected files & a 
range of Created 
& Modified 
dates 

About to email 
several files & 
want to know 
the total size? 
Use this

Get Summary Info



Show Inspector



Show Inspector shows the Multiple Item Info window 

(same name as Get Summary Info! 😐), giving you 

information about the selected files, folders, or apps 

To activate Show Inspector, select two or more files & 
use… 

» Press ⌥ & File > Show Inspector 
» Press ⌥ & right-click & click on Show Inspector 
» ⌘⌥I



They look the 
same! 

OK, Show 
Inspector has a 
shorter title bar 
(weird!) 

So what’s the 
difference?

Get Summary Info Show Inspector



I select another 
file by pressing 
⌘ & clicking on 
it 

Show Inspector 
dynamically 
updates Kind, 
Size, & dates 

Get Summary 
Info is static

Get Summary Info Show Inspector



Another example 
for Show Inspector







Open With 
& Change All



To change the app that file 
opens with, use the Open 
with menu & select a new 
app from the list 

To change the default for 
all files of that type, select 
the new app from the Open 
with menu & click on the 
Change All… button



Press Continue & now 
ebook-viewer is the new 
default



Contextual Menus



A shortcut menu (also called a contextual menu) 
appears when you select a file, folder, or app & then… 

» Right-click on it 
» Hold down ⌃ & click on it



You’ve undoubtedly seen this in your Web browser 

The menu changes according to its context — the menu 
differs when you click on a link, an image, text, or 
something else



Contextual menu for a 
webpage hyperlink



Contextual menu for a 
webpage image



macOS Finder supports contextual menus, but it also 
has some tricks up its sleeve



 Now press ⌥… 



Open With

Get Info

Quick Look

Copy



Open With 
➝ Always Open With



A default app is assigned 
to all files of a certain kind 

If you want a particular 
EPUB to open in an app 
different than the default, 
select Always Open With

BetterZip is set as the 
default for all EPUB files



Hold down ⌥ to change 
the app for this EPUB

Change the app for this 
EPUB to ebook-viewer



Now this EPUB will open 
in ebook-viewer, although 
BetterZip is still the default 
for all other EPUB files 

Remember, if you want to 
change the default for all 
EPUB files, see previous 
section Open With & 
Change All

BetterZip is set as the 
default for all EPUB files



Quick Look  
➝ Slideshow



Special Info



⌥⌘C copies the path of a file (⌘C copies the file, & the 
⌥ changes the behavior) 

Results in something like: /Users/scott/Movies/
Nosferatu (1922).m4v



Window 
Management



BetterSnapTool



BetterSnapTool allows you to easily set your window 
positions & sizes by dragging them to… 

» one of your screen’s corners 
» the top, left, or right side of your screen 

You can easily set your windows so they are… 

» maximized (not full screen) 
» positioned side by side 
» resized into quarters of the screen



Automation!













Demo!



www.boastr.net/bettersnaptool/ 

$3 on the Mac App Store 

If you buy BetterTouchTool instead, you can do what 
BetterSnapTool does & a lot more



Moom



Move, zoom, & resize windows 

(Yes, there is some overlap with BetterSnapTool & 
BetterTouchTool, but each does some different things)























manytricks.com/moom/ 

$10



Path Finder



Finder replacement & so much more



 Pane 1  Pane 2 

 Dual panes 



 Multiple tabs 



 Right Shelf  Left Shelf 



 Right Shelf  Left Shelf 



 Right & Bottom Shelf 



 Show Invisibles 



 Find Files & Folders 









File renamer 

Copy & Move to other 
folders 

Securely delete 

Copy & Move to other pane 

ZIP & move 

Sync folders



Email 

ZIP 

Cool plugins to do lots of 
things 

Open folder in Terminal 

Make CD/DVD 🤘







Path Finder 

cocoatech.com 

$40



ForkLife is another competitor to Path Finder 

www.binarynights.com/forklift/ 

$30



Renaming 
Files



Finder



Since Yosemite, macOS has the ability to rename 
multiple files (AKA, batch renaming) 

It’s very basic, but it’s enough for most people



Right-click on files or  
File > Rename n Items…











Path Finder



Of course this is built into Path Finder! 

Select files & press ⇧⌘R











A Better Finder 
Rename



Bulk rename files & folders



















Demo!



www.publicspace.net/ABetterFinderRename/ 

$20



Things Finder 
Cannot Do

(& How To Do Them)



Right-Click 
to Create New Files



In Windows, you can right-click & create a new file 

Apple doesn’t provide a method for that 

3rd-party software does, however





30 built-in templates











New File Menu 

langui.net 

$1.99 (only on the Mac App Store)



Thank you! 

scott@granneman.com 
granneman.com 
websanity.com

http://granneman.com
http://websanity.com
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Changelog 

2021-03-31 2.0: Created presentation using slides from 
the original Getting More From Your Mac



Changelog 

2021-03-23 1.8: Added how to copy & move files in Finder 
with key commands; added Installing Software section 

2020-06-23 1.7: Added section Get Info, Get Summary 
Info, & Show Inspector; add info re: macOS 11 Big Sur; 
added slide listing all Apple operating systems 

2019-08-16 1.6: Added Catalina for 10.15; added note that 
--- is not an em dash



Changelog 

2017-09-20 1.5: Combined naming charts in History; 
fixed minor formatting issues; added Thank You, Scott 
(⌘⇧/) to Basic Key Commands; added Terminal 
commands for disclosure buttons; added Show the 
Finder location of a file from a dialog box; added 
screenshot of Finder sidebar; added command for 
QuickLook slideshow; added Special Info in Finder; 
updated Mac prices for 2019; fixed QuickLook slides



Changelog 

2018-08-19 1.4: Added File Info & Actions section 
under Finder with Contextual Menus, Get Info, & 
Inspector; added HoudahSpot under Spotlight; added 
commands to open all disclosure boxes & Show Details 
for printing; added File Management section with New 
Folder with Selection; applied Granneman 1.4 theme; 
fixed minor formatting issues; added Sidebar under 
Components; more info on built-in security; added 
⌘⌃D in addition to triple-click for data detectors



Changelog 

2017-09-06 1.3: Fixed formatting; in History & added 
High Sierra; in Key Commands, added Alfred for 
clipboard; added slides re: holding down ⌥ in Open & 
Save; made deleting clearer in Movement; added slide 
about drop shadows in screenshots; added huge 
amount about Path Finder; added slides re: Finder 
renaming files; added lots of examples of Spotlight 
searches (RIP David Bowie); added New File Menu; 
added duration:, date:, & much more to Spotlight



Changelog 

2016-10-11 1.2: Changed Lazy is Good image; spread 
Automation throughout the deck; renamed Things You’re Not 
Doing Right to Finder & added lots more; added Spotlight 
section; changed menulets to status menus; added Quick Look 

2016-10-07 1.1: Changed theme; fixed formatting; added & 
changed a lot; new stuff on Finder, Printing, Key Commands, 
System Preferences, Tabs; added Computer Rules section; lots 
of fixes 

2016-03-13 1.0: First version
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