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2.4



Learn the key commands for macOS & your most-used 
apps 

It’s faster & more efficient



Do not to learn all these key commands at once 

Learn a few at a time that seem useful & master those, 
& then learn a few more



⌘ Command ⇥ Tab ␣ Space

⌥ Option or Alt fn Function → Right

⌃ Control ⌫ Delete ← Left

⇧ Shift ↩ Return ↑ Up

⎋ Escape ⌅ Enter (fn+↩) ↓ Down



Basics



Thank You, Scott



Can’t remember a command? 

Type ⌘⇧/ to open Help > Search 

Type a few letters, & it will show you the command



Press ⌘⇧/ …



Help > Search opens with the insertion point already in the 
search box



Start typing the letters of the 
command you want…



Select the command, & macOS 
shows you where the command is 
in the menus so you can learn 

Press ↩ & you run the command



Cut, Copy, Paste



⌘X Cut 

⌘C Copy 

⌘V Paste 

Do not ⌘C then ⌘V then go back & ⌦ — instead, use ⌘X 
then ⌘V

Your clipboard can hold any cut or copied item—text, 
image, video—but only 1 item at a time*

* You can change this with 3rd party software (e.g., Alfred)



⌘A Select all 

Very useful before using ⌘X or ⌘C



You can copy files in Finder with ⌘C & you can paste 
them with ⌘V 

You cannot cut files in Finder with ⌘X & then paste 
them with ⌘V 

You can copy files in Finder with ⌘C & then move them 
with ⌥⌘V!



Formatting



⌘B Bold 

⌘I Italic 

⌘U Underline 

Never use ⌘U — use either ⌘B or ⌘I (not both at the 
same time), but not ⌘U



Applications & 
Windows



⌘N New window 

⌘W Close window (or tab in Web browser) 

⌘Q Quit app 

⌘W should not quit an app, but ⌘Q closes all windows 
(although they will reappear when you reopen the app)



⌘⇥ switches between apps (→ direction) 

⇧⌘⇥ switches between apps in reverse (← direction) 

⌘` switches between windows in an app



iTerm

FirefoxWord

Word

Switch apps with ⌘⇥



Word Terminal FirefoxFinder

Keep pressing ⌘⇥ to switch apps



Word 2

Word 1

Switch windows with ⌘`



Word 1

Word 2

Keep pressing ⌘` to 
switch windows



Keyboard Maestro provides an even better Application 
Switcher than macOS does (more in Automation!)



What are the differences between apps & windows? 

macOS is an document- & app-centric OS 
» Focus is on working on documents within apps 
» Close the final document window, the app stays open 

Windows is a window-centric OS 
» Focus is on creating, viewing, & working within 

individual windows 
» Close the final window, close the app



Menu bars for each window



1 menu bar for all 
documents within an app



Command PromptFirefox

Word 1 Word 2



Word 1 Word 2

Command Prompt Firefox Desktop

Task Switcher shows 4 windows (from 3 apps) + Desktop





Word

Terminal

Firefox

Finder



⌘M Minimize (like clicking on the     in              ) 

⌘H Hide 

Hide is better than Minimize—especially if you switch 
apps with ⌘⇥



If you minimize an app’s windows & then use ⌘⇥ to 
switch to that app, its windows will not appear 

Why? Because you told the app to minimize its 
windows, so it keeps them minimized! 

If you hide an app’s windows & then use ⌘⇥ to switch 
to that app, its windows will appear 

Why? Because when you switch to an app, you 
obviously want to un-hide its windows!



∴, if you are a heavy user of the ⌘⇥ app switcher, you 

should always hide using ⌘H instead of minimizing



⌘T Open a new tab in tabbed apps, or open Fonts in 
non-Tabbed apps 

Remember that ⌘W closes a tab





Open & Save



⌘O Open document… 

⌘S Save work 

⌘⌥⇧S Save As… 

⌘⌥⇧S Save As is hidden by default, & it: 

1. saves the current document 
2. creates a copy of the current document 
3. closes the current document & 
4. starts working on the new copy



💡PRO TIP

Holding down ⌥ often reveals new or modified 
commands



Movement



⌘↑ Move insertion point to first line (beginning) of 
document 

⌘↓ Move insertion point to last line (end) of document 

⌘→ Move insertion point to end of line 

⌘← Move insertion point to beginning of line



⌥← Move left 1 word at a time 

⌥→ Move right 1 word at a time 

⇧⌥← Moves left 1 word at a time, selecting words 

⇧⌥→ Moves right 1 word at a time, selecting words



fn↑ Move up one screen 

fn↓ Move down one screen



Deletion



⌥⌦ Delete left (backward) 1 word at a time 

fn⌥⌦ Delete right (forward) 1 word at a time



⇧⌥← Moves left 1 word at a time, selecting words 

⇧⌥→ Moves right 1 word at a time, selecting words 

Then ⌦ to delete



⇧⌘→ Select all text from cursor to end of line 

⇧⌘← Select all text from cursor to beginning of line 

Then ⌦ to delete



⇧) Select all text from cursor straight up to next line 

⇧* Select all text from cursor straight down to next 
line 

Then ⌦ to delete



⇧⌘) Select all text from cursor to beginning of file 

⇧⌘* Select all text from cursor to end of file 

Then ⌦ to delete



Finder



⌘N Open a new Finder 
window (if you have 
checked Open folders in 
tabs instead of new 
windows in Finder 
Preferences, it will open a 
new tab instead)  

⇧⌘N Create a new folder 
titled untitled folder



⌘T Open a new Finder tab 

⌘W Close a Finder tab



Jump to various common 
folders



⇧⌘G Go to Folder… 

Very handy, especially if 
you need to get to a System 
folder that is otherwise 
hidden, e.g., /usr/bin or  
/Library/QuickLook







⌘D (File > Duplicate) Duplicate file or folder 

(Yes, I misspelled opossum 😬😧)





⌘F (File > Find) Search for files or folders





Fiona loved her pet possum Blossom



Screenshots



⇧⌘3  
Takes screenshot of entire screen 

⇧⌘4  
Takes screenshot of selected area by clicking & 
dragging 

⇧⌘4, then ␣, then Click  
Takes screenshot of selected window



Screenshot of entire screen





Screenshot of selected area





Screenshot of selected window





New in Mojave 

⇧⌘5 
Invokes Screenshot, a new app that displays a panel of 
tools for screenshots & screen recordings



Capture screen

Capture window

Capture area

Record screen

Record area

Capture or start recording





New in Mojave 

⇧⌘6 
Takes screenshot of Touch Bar



By default, screenshots of windows have drop shadows 
around them 

Ugly! Annoying! Unnecessary! Adds 50 px to all 4 sides! 

To change, open Terminal, type this on 1 line, & press ↩: 

defaults write com.apple.screencapture 

disable-shadow -bool true

Logout or reboot — the drop shadows are gone!



Or use OnyX…





Web Browsers



⌘R Reload a webpage 

⌘L Select everything in the address bar (so you can 
copy the URL with ⌘C, or type in a search term or URL)



Others



⌘Z Undo 

⌘Y or ⇧⌘Z Redo



⌘P Print



⌘F Find 

⌘G Find again 

⇧⌘G Find again, going backwards



⌘, Open Preferences for app



Symbols



Insert symbols not found on your keyboard 

System Preferences > Keyboard > Keyboard



Check the box next to Show Keyboard, Emoji, & Symbol 
Viewers In Menu Bar



Show Keyboard, Emoji, & Symbol Viewers status menu 
appears



Character Viewer



Double-click on a character to insert it



Customize the Character Viewer



⌃⌘␣ opens directly to Emoji, then double-click to 
insert



Keyboard Viewer



Keyboard Viewer with ⌥ pressed



Keyboard Viewer with ⇧⌥ pressed



En dash used for ranges: June–August 6–9 p.m. 

Em dash is the proper dash: “He thought—too late—
that he shouldn’t have eaten those burritos.”

Key Combo Result Name

- - Hyphen

⌥- – En dash

⇧⌥- — Em dash



-- or --- is not an en or em dash! 

“Those who don’t know better might use two successive 
hyphens to indicate an em dash-like interruption. In 
her book, Type Rules!, Ilene Strizver describes this as 
a ‘typographically incorrect and downright ugly 
practice.’”



Key Combo Result Name

⌥[ “ Left double quotation mark

⇧⌥[ ” Right double quotation mark

⌥] ‘ Left single quotation mark

⇧⌥] ’ Right single quotation mark 
& apostrophe



Key Combo Result Name

⌥; … Ellipses

⌥G © Copyright

⇧⌥K  Apple



Apps



Different apps have different, special key commands 

Learn them if it will help you work faster



Keynote

Key Combo Name

⌘⌥C Copy Style

⌘⌥V Paste Style

⌘⌥P Play Slideshow



Visual Studio Code

Key Combo Name

⌥⌘S Save All

⌥⌘F Find & Replace

⌘/ Toggle Line Comment

⌃` Toggle Terminal

⌃J Join Lines



You can create your own key commands if needed



System Preferences > Keyboard > Shortcuts > App 
Shortcuts







Select an app 

Type in the menu 
item exactly as it 
appears (use ⌥; to 
create the ellipses) 

Select a key 
command that is 
unique in the app 

Press Add





And now we have a key command!



(I also use Keyboard Maestro to create key commands—
more on that in Automation)



⇧



Notice what ⇧ (often) does: types an alternate to the 
pressed key(s) 

t outputs t, but ⇧t outputs T 

5 outputs 5, but ⇧5 outputs %



⌘S Save 
⇧⌘S Save As… 

⌘F Find 
⇧⌘F Find in Files 

F5 Start Debugging 
⇧F5 Stop Debugging 

Visual Studio Code



⌘R Reply… 
⇧⌘R Reply All 

⌘G Find Next 
⇧⌘G Find Previous 

MailMate



Dialog Boxes



⌘S to Save…



↩ selects

⎋ always closes

␣ selects



↩ selects

⎋ always closes

Acorn



⇥ moves 
between all 
form controls 
(including 
buttons) 

Use ↑ or ↓ & 
␣ to move & 
select

Acorn



⇥ moves 
between all 
form controls 
(including 
buttons) 

Use ↑ or ↓ & 
␣ to move & 
select

Acorn



␣ selects

↑ or ↓ moves 
between 
choices

Acorn



↩ selects ⎋ always closes

⇥ moves 
between all 
form controls, 
or groups of 
form controls 
(e.g., radio 
buttons) Path Finder



↑ or ↓ moves 
between 
choices

Path Finder



Open/Save 
Dialog Boxes



Some key commands only work in Open/Save dialog 
boxes



⌘D or ⌘⇧D jumps to the Desktop 

⌘⌥L jumps to Downloads 

⌘⇧O jumps to Documents



Various key shortcuts produce a sheet that lets you 
jump to a specific folder 

Press / to start at the root of your file system 

Press ~ to start at your home folder 

Press ⌘⇧G to start with the last folder you jumped to 
(which you can of course overwrite)



 After pressing /, you start at the root of your drive  



 After pressing ~, you start in your home folder 



 After pressing ⌘⇧G, you start at the previous folder 



⌘⇧. toggles between showing hidden files & folders 
(those that begin with a .) & hiding them again



 Now press ⌘⇧.… 





⌘⌥S toggles between showing & hiding the sidebar



 Now press ⌘⌥S… 



 Press ⌘⌥S to show the sidebar again 



⌘I shows the Get Info window 

(More on that later)



⌘F jumps to the Search field & from there you can 
search your entire Mac (or stick within the folder if you 
choose that)



SnagIt

This is not an macOS dialog box!



Thank you! 

scott@granneman.com 
granneman.com 
websanity.com

http://granneman.com
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Changelog 

2022-03-16 2.4: Added section on Finder in Basics, 
with several short videos 

2022-03-04 2.3: New OnyX for Monterey screenshot



Changelog 

2021-12-28 2.2: Updated description of ⌘L in Web 
browsers; updated formatting in Applications & Windows 

2021-06-06 2.1: Fixed minor formatting issues; explained 
why hiding is better than minimizing; made Deletion 
clearer & fixed error; switched from Brackets to Visual 
Studio Code for examples 

2021-03-31 2.0: Created presentation using slides from 
the original Getting More From Your Mac



Changelog 

2021-03-23 1.8: Added how to copy & move files in Finder 
with key commands; added Installing Software section 

2020-06-23 1.7: Added section Get Info, Get Summary 
Info, & Show Inspector; add info re: macOS 11 Big Sur; 
added slide listing all Apple operating systems 

2019-08-16 1.6: Added Catalina for 10.15; added note that 
--- is not an em dash



Changelog 

2017-09-20 1.5: Combined naming charts in History; 
fixed minor formatting issues; added Thank You, Scott 
(⌘⇧/) to Basic Key Commands; added Terminal 
commands for disclosure buttons; added Show the 
Finder location of a file from a dialog box; added 
screenshot of Finder sidebar; added command for 
QuickLook slideshow; added Special Info in Finder; 
updated Mac prices for 2019; fixed QuickLook slides



Changelog 

2018-08-19 1.4: Added File Info & Actions section 
under Finder with Contextual Menus, Get Info, & 
Inspector; added HoudahSpot under Spotlight; added 
commands to open all disclosure boxes & Show Details 
for printing; added File Management section with New 
Folder with Selection; applied Granneman 1.4 theme; 
fixed minor formatting issues; added Sidebar under 
Components; more info on built-in security; added 
⌘⌃D in addition to triple-click for data detectors



Changelog 

2017-09-06 1.3: Fixed formatting; in History & added 
High Sierra; in Key Commands, added Alfred for 
clipboard; added slides re: holding down ⌥ in Open & 
Save; made deleting clearer in Movement; added slide 
about drop shadows in screenshots; added huge 
amount about Path Finder; added slides re: Finder 
renaming files; added lots of examples of Spotlight 
searches (RIP David Bowie); added New File Menu; 
added duration:, date:, & much more to Spotlight



Changelog 

2016-10-11 1.2: Changed Lazy is Good image; spread 
Automation throughout the deck; renamed Things You’re Not 
Doing Right to Finder & added lots more; added Spotlight 
section; changed menulets to status menus; added Quick Look 

2016-10-07 1.1: Changed theme; fixed formatting; added & 
changed a lot; new stuff on Finder, Printing, Key Commands, 
System Preferences, Tabs; added Computer Rules section; lots 
of fixes 

2016-03-13 1.0: First version
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